Kompatibilität veralteter Shopware Versionen

Daniel Kazior/ Februar 17, 2022/ FAQ, Shopware 5/ 0Kommentare

ACHTUNG

Die in diesem Artikel beschriebene Vorgehensweise wird von CrefoPayment ausdrücklich nicht empfohlen! Der Einsatz einer veralteten Shopware Version birgt stets ein erhöhtes Sicherheitsrisiko; nicht nur in Bezug auf die Zahlungsabwicklung, sondern ganz besonders auch in Bezug auf den Schutz der auf Ihrem Server gespeicherten Daten Ihrer Endkunden!


Das aktuelle CrefoPay Shopware5 Plugin ist für die Installation aus dem offiziellen Shopware Store und für Shopware Version ab 5.6.0 (Release-Zeitpunkt: 12.08.2019) vorgesehen. Im nun folgenden Artikel wird beschrieben, wie das CrefoPay Plugin für ältere Shopware Versionen installiert werden kann.

Plugin als Zip-Datei Herunterladen

Für die Quellcode-Verwaltung unseres kostenfreien Shopware 5 Plugins nutzen wir ein GitLab Repository. Dort finden wir unter Pipelines im Reiter Tags die Builds der verfügbaren Plugin Versionen. Um nun an die benötigte Zip Datei zu gelangen, klicken wir auf den Package Schritt der Pipeline:

Wir gelangen so auf die Details zu diesem Schritt der Pipeline und navigieren von Dort aus über den Button Browse zu unserem Ziel:

Nach einem Klick auf den Dateinamen kann die Zip Datei heruntergeladen werden:

Plugin Kompatibilität anpassen

In der heruntergeladenen Zip Datei muss nun die Datei plugin.xml bearbeitet werden:

<?xml version="1.0" encoding="utf-8"?>
<plugin xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:noNamespaceSchemaLocation="../../../engine/Shopware/Components/Plugin/schema/plugin.xsd">
    <label lang="de">CrefoPay Payment Plugin</label>
    <label lang="en">CrefoPay Payment Plugin</label>

    <version>2.2.6</version>
    <link>https://www.crefopay.de/</link>
    <author>CrefoPayment GmbH &amp; Co. KG, Kellerkinder GmbH</author>
    <copyright>CrefoPayment GmbH &amp; Co. KG</copyright>
    <license>Apache-2.0</license>
    <link>https://www.crefopay.de/</link>
    <compatibility minVersion="5.6.0"/>
    
    <!-- .... -->

In der markierten Zeile wird die mindestens benötigte Shopware Version festgelegt. Ändern wir diesen Wert auch einen beliebigen kleineren Wert (z.B. 5.4.0), so wird die Installation für größere Versionen möglich.

Wichtiger Hinweis

Wird die Kompatibilität für das CrefoPay Plugin auf die hier beschriebene Weise modifiziert, besteht kein Anspruch auf Unterstützung durch unseren kostenfreien CrefoPay Support. Die ordnungsgemäße Funktionalität des Plugins kann in diesem Fall eingeschränkt sein oder unter Umständen sogar unmöglich sein.

Plugin installieren

Die im vorherigen Schritt modifizierte Zip Datei kann nun direkt über den Shopware Plugin Manager hochgeladen und installiert werden.

Hinterlasse einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

*
*